Qstarz 1000ex

lanthale's picture

I have now bought the first 10hz logger named Qstarz Xtreme 10hz (I think it is a 1000ex). The problem i have is that always when I download recorded points it hangs during download and never finished. In the console I am getting messages like "Expected:000C4800 Got:000C4000 (00000800)" or "Expected:000C4000 Got:000C9000 (00000300)".

After it hangs I can just click on disconnect and afterwards convert, but only see the received data until it hangs, never the hole data. Is there a chance that BT747 is supporting that device ?

lanthale's picture

I have now tried to download

I have now tried to download data over Bluetooth with the device address (on a mac it is /dev/cu.Qstarz1000EX-SPPslave). This is working fine. But settings cannot be made using bluetooth because than the device hangs.

The result is:

  • Download data and erase the device over bluetooth
  • Make settings such as the recorded format and upload AGPS do it over USB with the SiLabsUSB Driver (From the Silabs driver homepage)

I have a QStarz BT-Q1000ex

I have a QStarz BT-Q1000ex (5Hz, the previous generation) on Mountain Lion. I connect using USB. Mine used to hang all the time until I read the comment here to change the Chunk Size to 512 (under Advanced Device Settings).

lanthale's picture

I will try that and will see

I will try that and will see if changing the chunk size is also the solution on windows (I am using BT747 on Windows as well started from the same directory).

By the way I had to change the source code for a working bluetooth version. As soon I have time I will checkin the changed source files. The issue was that the actual implementation could not find any device and have not tried any via  bluetooth connected devices under OSX. I must test if the change is working under Windows as well.

mdeweerd's picture

Ok, the current

Ok, the current implementation for finding bluetooth devices is by checking if one of the known paths exists. 

Post new comment

(If you're a human, don't change the following field)
Your first name.
(If you're a human, don't change the following field)
Your first name.
The content of this field is kept private and will not be shown publicly.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <p> <br>
  • Lines and paragraphs break automatically.
  • Use the special tag [adsense:format:slot] or [adsense:format:[group]:[channel][:slot]] or [adsense:block:location] to display Google AdSense ads.
  • Images can be added to this post.

More information about formatting options