No connection to logger

fortwienix's picture

Hi,

I am using the iBlue 747A+ with the BT747 2.X.1688 Software. So far all went successfully until now. I hit the button "try to read from corruped memory". Nothing happend. But since then I cannot connect to the device any more. The COM port is correct, but the software doesn't get any data from the logger, it's not even able to recognize the model etc.

Also the original software GpsView is not able to connect to the device.

Is there any way to reset the device without the software? I did remove the battery but nothing changed. My last try is to remove the battery for some hours, but I assume this may not help.

Any help is very appreciated.

fortwienix

mdeweerd's picture

Removing the battery is a

Removing the battery is a good idea, but 10 seconds is largely sufficient.

BT747 detected that the log memory was corrupted somehow and was apparently even unable to do a read operation.

If you are able to connect somehow anyway, you can try a 'Recover Faulty Memory'.  That will likely be unsuccessfull if there isn't any other indicator of a successfull connection.

The last resort would then be to perform a firmware update/restore.  For that you need the firmware image & I am not sure that one is out there in the public.  It is possible to retrieve a firmware image if the procedure is the same as the iBlue 747A+ predecessors.  Before doing that, it would be best to try the above.

fortwienix's picture

Hi, Thank you for your

Hi,

Thank you for your help.

The problem really got solved removing the battery for several hours. Then I switched it on into log mode and let it run for a while. Now I just checked whether I am able to connect and read the memory. Fortunately this was working.

All operations are working again (I assume), at least I was able to adjust the specific settings for logging again. The firmware update would have been another try, but I didn't search for that yet.

The original documentation of the device is very poor. Thanks to this BT747 software the logger is a lot more useful.

mdeweerd's picture

Thanks for the update. Given

Thanks for the update.

Given what happened, it might be a good idea to do the recovery anyway.  That gives the memory a kind of clean start.

maria99051's picture

Nice to see you all , i have

Nice to see you all , i have a Qstar BT-Q1000Ex and i have connected it to my phone at same time but there is an error showing that " no connection data logger " You need to help me there 

mdeweerd's picture

You are trying the phone

You are trying the phone verison of BT747 or the desktop version of BT747?

You should not connect using USB and Bluetooth at the same time.

I recently am unable to

I recently am unable to connect to my Qstarz 1000ex as well on my win764 machne.  I have been running the version 2.03 stable for some time and was successful in downloading data from the logger. As of tonight, I cannot get the application to connect.  I've tried the Qstarz travel app and it worked fine (and told me which comm port to use).  I downgraded to an earlier verison of Qstarz without success in connecting. 

In trying to figure out what might have changed on the system, recently a Firefox browser update forced download and install of a new Sun Java package, build 1.6.0_31-b05.  Could this updated Java version be the problem?  I tried the lastest development build of Bt-747 (2.x.1955 from April 1st) without success.

I tried the desktop version

I tried the desktop version and that worked fine.  I suspect the Java update is the problem.  Is this jnlp file I downloaded a link to the java files that gets loaded each time from the web?  No problem I guess if I am on the net, but I'm wondering if there's an executable version in the works for the new Java from Sun for when offline? Thanks, Wayne

mdeweerd's picture

Hi I cleared my java cache

Hi

I cleared my java cache (on windows) to force getting the most recent version.  To do so, go to the control panel, find 'Java', then in 'General', click the bottom right button (to visualize temporary internet files).  There, find 'BT747' in the application group and click 'X' to remove it from cache, in the 'Resources' group, find enties the start with 'http://soft.bt747.org' for the URL (you can select a group by holding CTRL(-SHIFT) while clicking) and click X.

Then go to 'http://soft.bt747.org' and select one of the versions to start.

 

When you select a version with 'Install' in the link, then java should (propose to) create a link on the desktop or in the menu - in these cases you'll have a direct link to BT747 that you can use offline.  To improve offline experience, you can also set the 'Map cache directory' in BT747 (see the file menu) to a valid directory - BT747 will store the map tiles there - any map tile that you viewed while online will be available offline - the user experience is also improved.

 

I am not sure how the java update impacted the correct operation of BT747 - I just checked several versions (from soft.bt747.org) on my Win7/64b machine and they work (connection, ...).

Just had a similar

Just had a similar problem.

It turned out that something was having an issue connecting to the GPS device via the USB hub in my monitor.  None of the USB ports on the monitor worked, but all of the ones directly on the motherboard worked fine, so if you are connecting via a USB hub or any kind it might be worth trying a direct connect instead.

Post new comment

(If you're a human, don't change the following field)
Your first name.
(If you're a human, don't change the following field)
Your first name.
The content of this field is kept private and will not be shown publicly.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <p> <br>
  • Lines and paragraphs break automatically.
  • Use the special tag [adsense:format:slot] or [adsense:format:[group]:[channel][:slot]] or [adsense:block:location] to display Google AdSense ads.
  • Images can be added to this post.

More information about formatting options