Logging Active goes off when MBT-1100 powered off.

I’ve just started using BT747 v2.x1770 with my RoyalTek MBT-1100


I have a problem with the ’Logging Active’ always resetting when I power off the device.


Whenever I turn the unit back on, I need to reconnect it to my PC (or Phone) to re-enable logging.


Have I missed an obvious setting somewhere?


 Everything else works (when logging is on)

mdeweerd's picture

This does not look like

This does not look like normal behaviour.  It would be interesting if you can capture the 'connection' log (activate the 'GPS Connection Debug' in settings, then connect to your device & let things settle a bit, then disconnect, then look in the Output folder for a file called 'gpsRawDebug.txt').

 

After that you can try a 'Factory Reset' & a 'Try to recover faulty memory'.  Your memory is not faulty, but as far as I remember, somewhere in these procedures this logging behaviour is also 'reset' - and I think it is in the memory recovery feature.

I'll be on vacation for the coming weeks so you'll probably not have more hints than that.

Thanks for the reply. I tried

Thanks for the reply.


I tried the suffestion but it hasn't made a difference.
I went back to the RoyalTek software and even that can't keep the logging setting turned on any more - i.e. I set logging to 'By Time' (instead of by button) and stored the settings. If I disconnect and reconnect, the setting is maintained. If I power off and on, then the setting is lost.
I used the logger a few times when I got it last week - using the factory settings and it logged perfectly after a power cycle. It was only after trying to configure with BT747 that I noticed this problem. As far as I recall, I noticed the problem after setting 'Time+Speed+Distance logging' - which it did succesfully. but when I powered off and on the next day it logged only on a button press.


I have tried all combinations of resets/formats but none of them get the unit to retain the logging state after a power off. The Java app is working fine on my Nokia 2330 so I simply enable logging using the BlueTooth whenever I need it but it's just a little  bit of a pain.


I have collected a log - what should I be looking for?

Problem Fixed.RoylaTek sent

Problem Fixed.
RoylaTek sent me new firmware. The logging state is now retained after a power cycle.


Now I'll go and log something and test the rest of BT747 :)

More information if it helps

More information if it helps anyone else -
The information displayed in BT747 after the firmware update is ...
   FlashInfo: 20201710 (STM,8MB)
   Model:     000A (Royaltek MBT-1100)
   Firmware:  B-core_1.1 (MBT-1100)
   Logger SW: V1.39


Sorry, I didn't note the settings before the update.
If anyone else needs the files, then reply here and I'll send them on.

Hello, Same things happens to

Hello,

Same things happens to me too.

Did you contacted Royaltek via email?

If would be nice to have the file.

Thanks,

Adrian

You can contact me at

You can contact me at "adryyandc" aat "yahoo" doot "com"

mdeweerd's picture

Good to see that there is a

Good to see that there is a solution to it ;-)

The new firmware seems to

The new firmware seems to introduce a new bug...

mdeweerd's picture

Ha - you sure know how to

Ha - you sure know how to keep the suspense ;-).  What seems to be the bug?

If you set he logger to not

If you set he logger to not log (or log by push button) then restart the device, it will start in Log by time mode (Loggin Active).

Also i suspect that log by push button is not working anymore.

It would be nice to have the old firmware too even this is more confortable.

If you have any suggestions please let us know.

Adrian

mdeweerd's picture

Try setting the speed

Try setting the speed condition to a ridiculously high value.  That way you'll have at least one log condition set which will not occur in practice (e.g., speed to 900 km/h).

To check 'log by push': make sure that 'RCR' is logged and check in the RCR field that there are 'B' type positions.  In principle you do not need to log RCR - it is just to check.

RCR field was checked. Can

RCR field was checked.

Can factory reset do something for this issue? Is risky to try it?

Adrian

mdeweerd's picture

I've done factory reset

I've done factory reset myself and other people too and it looks safe.  In principle it should not change anything about it.

mdewwwrd, can you explain

mdewwwrd,
can you explain what you mean by 'check in the RCR field that there are 'B' type positions' ?

mdeweerd's picture

When you convert the '.bin'

When you convert the '.bin' file to some other format, you'll also get the tables 'Track' and 'Waypoints' in the GUI where you have a column that is called 'RCR' which means 'Record reason'.  The column next to it is a textual description for that.  A 'B' corresponds to 'Button'.  So if you have B's in the RCR column that means that the button did work (at least for certain positions).

I just tried .... time=0s,

I just tried .... time=0s, speed=999km/h, distance=0.
Cleared the memory, powered the device off+on. pressed the button every 10 seconds for 1min. Connected to BT747 and no data was logged.


looks like the firmware update permanently puts the logger into time/distance/speed only mode.


Thats fine for me as thats what I wanted but maybe not for everyone.


 

mdeweerd's picture

The partially good news is

The partially good news is that the '999km/h' setting seems to work and is not reset.

However, the button should continue to work - as far as I kno there is no software function to enable/disable the button.

My only use for the logger is

My only use for the logger is for image tagging so the lack of button is no problem.
So far I have not tried it on images as I can't tag raw files (Canon .CR2) with BT747.


The new firmware has two problems as far as I can see ...
1. You can no longer use the button for manual logging.
The device cannot be configured for 'Button Only' and it will not recognise the button in 'timed/speed/distance' logging.
2. The time required to press the button for power on/off is very short.
Previously I had to hold the button for 4-5 seconds to turn the logger on/off.
Now it is less than 0.5 seconds. I have accidentally turned it off a few times by knocking it in my pocket.


I have contacted RoyalTek again but I don't expect any new firmware.

For what its worth, Looking

For what its worth, Looking at the Downlaod list now, There is seperate software for "Log by time" and "Log by pushbutton". It seems to me that they're separated those 2 functionalities in both the download software and the firmware, If you're not using their software it'll not be a problem, but the firmware...

mdeweerd's picture

I've looked at what these

I've looked at what these utilities do.

They mostly use the same commands.  there are two new commands for which I do not know the meaning though - but they seem unrelated to this (it might be interesting to know that the response from an actual device is).

Basically, Log By Time sets 'Autolog' on and Log by Button' Only sets 'Autolog' off.  When Autolog is off, time, distance and speed conditions are ignored.

Maybe a change in the firmware is that when autolog is on, the button press is ignored.

I do not show the 'Autolog' status in BT747 - maybe I should add that and set autologging 'off' when all conditions are off or just have the user control that.

I have the same problem. And

I have the same problem. And the firmware is the same as you mentioned.

Do you have new firmware? How do you flash this?

Thanks.

 

Max

Please send firmware to

Please send firmware to rickgtx-at-gmail-dot-com.

 

Thanks

rickgtx's picture

I can confirm this firmware

I can confirm this firmware upgrade disables the log-by-button feature on the MBT-1100.  The button is only for on/off now.  Note that your bluetooth device name and address changes.

The information displayed in BT747 before the firmware update is ..  (See post #4 for the after info)

FlashInfo: 20201710 (STM,8MB)
Model:     0007 (Just Mobile(r) Bluecard)
Firmware:  B-core_1.1 ()
Logger SW: V1.39

Copy of the firmware is at http://www.megaupload.com/?d=FIF0S8IP

I can confirm this firmware

I can confirm this firmware upgrade disables the log-by-button feature on the MBT-1100.  The button is only for on/off now.  Note that your bluetooth device name and address changes.

<a href="http://www.michaelkorsoutlettsale.com/">Michael Kors Sale</a>
<a href="http://www.michaelkorsoutlettsale.com/michael-kors-jet-set-c-39.html">Michael Kors Jet Set</a>
<a href="http://www.michaelkorsoutlettsale.com/michael-kors-purses-c-40.html">Michael Kors Purses</a>
<a href="http://www.michaelkorsoutlettsale.com/michael-kors-satchels-c-41.html">Michael Kors Satchels</a>

Post new comment

(If you're a human, don't change the following field)
Your first name.
(If you're a human, don't change the following field)
Your first name.
The content of this field is kept private and will not be shown publicly.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <p> <br>
  • Lines and paragraphs break automatically.
  • Use the special tag [adsense:format:slot] or [adsense:format:[group]:[channel][:slot]] or [adsense:block:location] to display Google AdSense ads.
  • Images can be added to this post.

More information about formatting options