Checked filter but still no points found

phr33's picture


So, I'm tried to get BT747 up and running with my Holux M 1200-E. It connects just fine and I can alter device settings etc.

The device contains a couple of tracks and I can see that there are some 2500 points in memory. I can download the log but when trying to convert it states that no points were found and I should check the filter. I also saw the topic mentioned in the faq. So, I double checked my filters and check all fix types as valid, no common filters etc. Date range is also set very generously. Still no track points :\


So any clue what I could try next?



mdeweerd's picture

Did you select the right

Did you select the right device type (not 'default', but Holux GR-245 should do the trick)?

phr33's picture

Yepp, tried changing device

Yepp, tried changing device type aswell :\


But hey! "Convert to table in GUI" worked! It showed up on the map :)


So... is there some difference between what points should be converted to GPX and to table in GUI? Couldn't find any such indications.

The app seems great though. Just what I wanted for my little GPS device :)

mdeweerd's picture

What version are you using -

What version are you using - can you try this with the development version?

There was an issue similar to this in NMEA but that was solved and not present in GPX.

If you still have this issue in the development version, can you send me your bin file and BT747SettingsJ2SE.pdb located in %USERPROFILE% on windows or your home directory on Linux/Mac.

phr33's picture

I run the normal desktop

I run the normal desktop version. Tried the development version aswell, same problem.

I attach the files in a zip.


Kudos for the quick replies :)




File bt747_files.zip90.47 KB
mdeweerd's picture

Hi The issue is the '%c' in


The issue is the '%c' in your output filename specification where you should also remove 'Z:\'.

I remember implementing what I mention here but I do not find it in the code...  I wonder what happened and I am looking further to find the 'fix'.

BTW, I've been a few times in Lund ;-).

mdeweerd's picture

Ok, I got it.  The code is

Ok, I got it.  The code is there ;-).

The reason for the issue is that the '%c' results in a filename like this:


which is not valid on windows due to the ':' tokens.

The next filename specification works:


phr33's picture

Ah. I tried without %-stuff

Ah. I tried without %-stuff aswell. But you got me testing other things related to naming now and I found what was causing my error!


I set my output folder to z:\ 

Clicking "Outup file prefix" and typing in a prefix, "GPSDATA2" gives a total field value of "Z:\GPSDATA2"

I guess the value is appended to the output folder giving "Z:\Z:\GPSDATA2" wich of course is invalid.

I shouldn't have used the buttons but just typed in myself in the text fields cause the labels hints the right behaviour.


Maybe the buttons behave differently for other OS's? I run Win7 Pro 64-bit on the machine I played around with.


So summary: The "File output prefix" should only contain a prefix, NOT an entire path (as assigned by the button).



mdeweerd's picture

Hi Martin As I wrote: "The

Hi Martin

As I wrote: "The issue is the '%c' in your output filename specification where you should also remove 'Z:\'."  You probably skipped the last part in that sentence.

I have Win7 64b pro and this works as expected - the only thing is that when you use the 'Output File Prefix Button', BT747 tries to determine the relative path to the OutputFolder + the filename prefix.

But hey, you got it now.