AGPS issue (2.1.0)

mdeweerd's picture

I just got the following message:

An old problem is back:
Today i cannot download AGPS data with Version 2.1.0  :-(

Can you confirm and fix it?


So I had a look.  In fact it is not the old problem, but a new problem and you can blame Filezilla for it (strangely enough, filezilla is the server that is used, and it probably got updated to a beta version).

I implemented a workaround and it is available in 2.1.1.

To update, you may need to delete your java application cache.  On windows you can launch the command 'javaws -viewer'.  Then delete BT747 from the cache and get the software again from
Or get BT747 again as you did before.



On OSX10.9 the 'javaws

On OSX10.9 the 'javaws -viewer' and reinstall also fixed my agps issue.


Btw, it would be great if the file location could be changed within the gui,

or at least could some one explain how I add the info in the gui, or it would be cool to have

a plain text config file to edit such settings.


I one tried it,  I can also see a string with a different address in my config file (I tried to add the 14day epo file)

but I still it uses the standard account and uploads the 8d file.


So my two questions:

* is a 14 day file supported on my QSTARZ XT

* how do I set it up on my mac

mdeweerd's picture

Hi The URL can be set form


The URL can be set form the command line (see /book/agps).

Currently BT747 gets the 8d file.  I have to check the XT to see how many days the devices retains.  If you only see 7 days worth of data after uploading the AGPS data, you know that the device only supports 7 days.

If somebody confirms that there is a device supporting more than 8 days, I'll update BT747 to get the biggest file.

There no real use in being able of changing the URL in the GUI.  The issues were more related to the java library or the ftp server.  BT747 has workarounds for that (internal FTP handling and workaround for the FTP server).

Kind regards