Snow Leopard

Michael's picture

hi! has anyone tried to use mac os x snow leopard with bt747? after my upgrade to snow leopard, bt747 can't connect to my iblue 747+.

mdeweerd's picture

Hi Can you check that a new

Hi

Can you check that a new device appears in the device list when you connect your device to the computer?
You can do this by checking the /dev directory.
I do not know the most efficient way to do that on a Mac, but you could redirect the directory contents to a file before connecting, then connect, redirect the same directory contents to another file and then compute the difference between these files to find the new port.

There are several things that may go wrong:
1) No driver support integrated in the installation: probably no new device will appear in the list;
2) The device name changed and you need to change the path to the device. The generic option (USB for mac, linux) will look for known device paths, but you can also type a precise path in the box (/dev/yourdevicename).

So check that out please and report back here.

simospa@gieffeedizioni.it's picture

Hi I'm going to upgrade too

Hi

I'm going to upgrade too so I can just guess...
SLAB to UART driver needs an upgrade to v. 2.1 to work with snow... you can find it there
https://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx

From the command line you can check the version...
CP2101 USB to UART Bridge Controller Driver version V1.02.2

Simone.

It seems that under Snow

It seems that under Snow Leopard Terminal runs in 64-bit and looks like Java too which makes some images(?) non-working since there is no 64-bit code... Or, I don't know. Anyway, I've installed drivers but M-241 still doesn't work. There is a message in the Terminals' window when I'm searching for the ports

java.lang.UnsatisfiedLinkError: /Users/ajax/Downloads/BT747/lib/rxtx-2.1-7-bins-r2/Mac_OS_X/librxtxSerial.jnilib: no suitable image found. Did find: /Users/ajax/Downloads/BT747/lib/rxtx-2.1-7-bins-r2/Mac_OS_X/librxtxSerial.jnilib: no matching architecture in universal wrapper thrown while loading gnu.io.RXTXCommDriver
Exception in thread "Thread-3" java.lang.UnsatisfiedLinkError: /Users/ajax/Downloads/BT747/lib/rxtx-2.1-7-bins-r2/Mac_OS_X/librxtxSerial.jnilib: no suitable image found. Did find: /Users/ajax/Downloads/BT747/lib/rxtx-2.1-7-bins-r2/Mac_OS_X/librxtxSerial.jnilib: no matching architecture in universal wrapper
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1878)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1795)
at java.lang.Runtime.loadLibrary0(Runtime.java:823)
at java.lang.System.loadLibrary(System.java:1045)
at gnu.io.CommPortIdentifier.(CommPortIdentifier.java:83)
at bt747.j2se_view.BT747Main.access$3200(Unknown Source)
at bt747.j2se_view.BT747Main$36.run(Unknown Source)

Hello, I am having issues

Hello,

I am having issues too...

My setup (iMac Intel/iBlue 747 A+) was working well until Snow Leopard. I have been able to get a connection again by firstly selecting File>Find Serial Ports and then use the tty.usbmodem26230 setting.

The GPS Device Data reports correctly (device type, memory usage etc.) and I can create a BT747log.bin file which is 4.2Mb when doing a full download.

My problem is that when I try and create a GPX (or any other format) file, I get a warning saying that no output file was created because no data was found (or similar).

Any ideas on how to diagnose what is going wrong ?

Thanks

Mark

mdeweerd's picture

If running 64 java, you

If running 64 java, you probably need to use the new RXTX drivers. The startup script is likely best updated using something like I did on Linux. The new driver is in 'rxtx-2.2pre2-bins/Mac_OS_X/mac-10.5' and you can edit the scripts ( bt747_macosX.command bt747_macosX_j2se.command) so that the 'RXTX_PATH' environment variable points to this new location. To be generic, this script would best check the OS version that is running and point to the appropriate location automatically. You can also try this new driver directly from the web (http://www.bt747.org/webinstall ) where you have this link: BT747 Latest using RxTx 2.2pre2 (RxTx dev version) for Windows 32 & 64 bit, MacOSX, Linux. Regarding the issue with log format conversion: make sure that your position filters are appropriate. Disable the common filter and check about every other checkbox that you see. You will select all positions, but at least you'll know you have a filter issue. You can then retuen the filter as needed. Also make sure that the device type is set to 'Default' in case of the iBlue 747A+. If you still have trouble, I can check out your log if you send it to me.

mdeweerd, second link works!

mdeweerd, second link works! Thanx!! :)

I had continuos issues with

I had continuos issues with "standard" installation also before snow leaopard. As is: download, start, working. Close, reopen, java errors about missing libraries or not compiled for the right architecture. Nightmares (and I'm an hobbist programmer).

Nevertheless, the "BT747 Latest using RxTx 2.2pre2 (RxTx dev version)" version always worked for me. It's a bit a pain to have always to start it online (from the .jnlp), but it's the only reliable way I found to start it right. And it works with Snow Leopard too :)

Cheers

OK, I have got connection via

OK, I have got connection via /dev/tty.usbmodem1a20

I am using BT747_J2SE_Latest_rxtx2_2p2.jnlp and all now seems OK

I think I just didn't have any data, hence the error in the log.

Thanks for spending the time to help !

Regards

Mark

Hi, I installed SL a couple

Hi,

I installed SL a couple of days ago and today was the first day I tried using BT747 Desktop since then. When I clicked to start BT747 Desktop, it found a new version, downloaded the new version and tried to install that. Unfortunately I got the message:

"Unable to launch the application."

I've tried uninstalling / moving to the trash the previous version of BT747 and this new downloaded version. I then tried re-downloading and installing BT747 Desktop from the bt747.free.fr website but kept getting the same message.

I'm brand new to the Mac format and couldn't make out the information in the "Details" section of the error message.

Can anyone please help? If this doesn't work, is there an alternative to BT747 that would work on SL? Should I bite the bullet and re-install Leopard?

Much appreciated.

Hi there, I'm lost. I've been

Hi there,

I'm lost. I've been trying to get this to work for an hour without success. I am using Snow Leopard on my MacBook and I know that the computer can see and identify the GPS (I'm using the QStarz BT1300 connected by USB) because I can download the tracks to Photolinker and geotag my photos in there without so much as a hiccup. But BT747 won't budge. It doesn't connect, it doesn't do anything if I choose find serial ports.... the program opens ... and that's about it.

I've tried every version I can find, I've installed the drivers suggested on your site, I've done the Sudo commands.... nothing works.

I'd really appreciate some help.....because right now I have a wonderful little GPS that I can't delete track files from, only download using another program that doens't have delete capabilities built in.

Sincerely,
Paige

raymac74's picture

Hallo, I'm a newby at this

Hallo,
I'm a newby at this site and at gps data logger world.
I've got a i-Blue 747A+ and an iMac white 24" with Mac OS 10.6.1 (Snow Leopard).
I tried to install the program bt747 from webinstall and from zip pack always with bad results.
I installed the SiLabsUSBDriver, made this command in the shell:
sudo mkdir /var/lock
sudo chmod 777 /var/lock
but I was never be able to connect my device to my Mac.
I tried by USB port and by Bluetooth port (the device was recognized but not supported, red point in the network/bluetooth device list in the system preference).
I'm a newby also with terminal app, so I need a guide step by step for preparing the OS and installing this useful software.
I tried to install bt747 in Win XP by VMWare Fusion and everything was ok!!
I'll wait your help a.s.a.p., thanks in advance

Andrea

mdeweerd's picture

There seem to be some issues

There seem to be some issues in Snow Leopard as you can see. The SiLabsUSBDriver wil not help you with your A+ device - it uses another USB-to-serial bridge.
Please try the link "BT747 Latest using RxTx 2.2pre2 ..." above or from the webinstall page. I do not have a mac so it is difficult to be precise.

Personnally I would recommend not to upgrade to Snow Leopard yet - Apple already released a patch just after the roll out and I expect some more to come. I'ld sit it out for a while and stick with the previous version of the OS.

I've recently upgraded to

I've recently upgraded to Snow Leopard and had the same issues as described, but with the "BT747 Latest using RxTx 2.2pre2 (RxTx dev version) for Windows 32 & 64 bit, MacOSX, Linux" version everything is ok.
Now I'm starting i from a web shortcut on my desktop but I'd like a standalone release or a web desktop autoupdate that works.

Thanks Mario!

mdeweerd's picture

Excellent. Maybe somebody can

Excellent.

Maybe somebody can help adjusting the launch script for MacOSX. Basically, the latest zip distributions have all the required files, but the startup script needs adjustment.

It would be best that that script detects whether the system is snow leopard or higher to use the new RXTX only in that case.
The new RXTX is in lib/rxtx-2.2pre2-bins/Mac_OS_X/mac-10.5 while the previous one is in lib/rxtx-2.1-7-bins-r2/Mac_OS_X.
The startup script is bt747_macosX_j2se.command. In that script the following lines have to be adjusted:
RXTX_PATH=${ROOT_DIR}/lib/rxtx-2.1-7-bins-r2
RXTX_BIN_PATH=${RXTX_PATH}/Mac_OS_X

The best way to do so is to do so based on an os version test:

if [ `arch` == "expected_old" | ... ] ; then
RXTX_... = ...
else
RXTX_... = ...
fi

It may be that the use of 'arch' is not good enough, so I'll let somebody with a mac system find that out.

Before doing the 'if' stuff, one can already do a permanent modification of the lines indicated earlier to point to the new RXTX version. Also, please post the first 10 lines or so that appear in the 'Info' window on snow leopard to know how java identifies the system - I can use that for the webstart.

simospa@gieffeedizioni.it's picture

To ask osX

To ask osX directly...

ISSNOWLEOPARD=0
system_profiler SPSoftwareDataType | grep 'System Version: Mac OS X 10.6' >/dev/null \
&& ISSNOWLEOPARD=1

Sorry, it's not going to snow on my leopard so I can't test.

Have a nice day!

Simone.

mdeweerd's picture

Hi Can somebody try the

Hi
Can somebody try the 'default launch methods' (from http://www.bt747.org/webinstall).
I changed the rxtx configuration so that it loads the beta rxtx version for Mac OS X 10.6.
If any new version number appears, I'll need to add it though.

mdeweerd's picture

I atached updated startup

I atached updated startup scripts for MacOS : one is for the desktop version (j2se) the other for the pda version.

Please test this on pre 10.6 systems (=10.4, 10.5,...) and 10.6 systems (=10.6, 10.6.1) and leave a comment here regarding failure or success [one report for each is good for me].

AttachmentSize
File bt747_macosX_j2se.command1.72 KB
File bt747_macosX.command2.29 KB
simospa@gieffeedizioni.it's picture

Hi. Startup scripts are

Hi.
Startup scripts are working fine on 10.5.
Webinstall works too on development versions.
"Try the Desktop version", or install, are not working (log attached).
Hope it helps!

Simone.

AttachmentSize
File errors.txt1.25 KB
mdeweerd's picture

Hi Simone Is that for 10.5 ?

Hi Simone
Is that for 10.5 ? Or for 10.5.something?
Mario

raymac74's picture

I trid to install the version

I trid to install the version “BT747 Latest using RxTx 2.2pre2” as suggested in the note here:

http://www.bt747.org/node/225

but, as before, I’m not able to connect my i-Blue 747A+ with my iMac (OS X 10.6.1) via USB.
I’ve before installed the “SiLabsUSBDriver”, maybe this driver can give me some problem?
I saw this command script:

http://www.bt747.org/webfm_send/2

posted by “mdeweerd” but I don’t know very well how apply this one. I tried to drag it in the shell but it tell me that I’ve not the permission........
I’ve not experience with shell and UNIX/Linux OS.
When you are ready with this working version on 10.6, could you please post a step by step guide for installing this program?
Thanks

raymac74

simospa@gieffeedizioni.it's picture

Hi Sorry... It's

Hi
Sorry... It's 10.5.8.
Don't know if it matters, but I have apple's developer tools installed.
Simone.

mdeweerd's picture

@raymac74: The iBlue 747 A+

@raymac74: The iBlue 747 A+ does not use the SiLabs chip so that driver should not make a difference. The script must be made 'executeable' using 'chmod +x ...' for instance (or I guess a properties dialog). The latest upload 2.X.1522 (zip) has the updated script too.

@simone: The list of Mac OS X versions did not include 10.5.8 in the webstart description. I updated the list - hopefully it is ok now (please launch two times - I noticed that the update is not always effective after the first time).

simospa@gieffeedizioni.it's picture

Hi Mario. Tried again but I'm

Hi Mario.
Tried again but I'm having luck only with 'Try Development version' on 10.5.8: java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path
Also tried on a 10.4.10. The application itself starts, but I'm not able to see the device (when I plug it no new devices appears in /dev).

Simone.

mdeweerd's picture

Given the trouble to make a

Given the trouble to make a distinction between old and new mac systems - all mac systems will now get the 'new' beta RXTX through webinstall. Hopefully that works.

simospa@gieffeedizioni.it's picture

Same again, but on another

Same again, but on another mac (same os) it works...
Maybe some cache?
Thank you.

Simone.

mdeweerd's picture

Please launch twice at least

Please launch twice at least - if it still does not work: try to activate the java console and send me the info in there.

simospa@gieffeedizioni.it's picture

Hi! Fixed! It was a cache

Hi!
Fixed!
It was a cache issue, even launching it many (and many more!!) times...
From the command line:
javaws -uninstall BT747_J2SE.jnlp
and then it works.

Thank you.

Simone.

raymac74's picture

@ mdeweerd: > The iBlue 747

@ mdeweerd:
> The iBlue 747 A+ does not use the SiLabs chip so that driver should not make a difference.

Ok, this driver doesn't help me with iBlue 747 A+. Can I let it installed or have I to disinstall it?

I iNstalled the "The latest upload 2.X.1522" via webinstall with no good results, why?

> The script must be made 'executeable' using 'chmod +x ...' for instance (or I guess a properties dialog). The latest upload 2.X.1522 (zip) has the updated script too.

This script has to be lunched or not? It seems to be included in the "latest upload 2.X.1522", isn't it?

Thanks

mdeweerd's picture

Hi This slipped out of my

Hi
This slipped out of my focus.

a. In principle you should be able to let the driver installed.

b. Difficult to say with the information I get here. Could you share some log files with me. It would be a good start to share what appears int he 'Info window' when you try to connect. Also share what your serial port is. Try to do a 'Find serial ports' from the file menu and look what is added at the end of the list of the ports. Select the most appropriate one and try to connect.

c. The latest upload has this script indeed and that script has been improved again in 1533. In case you did not notice: in the left border of this site there is a "Posts from elsewhere" which groups RSS feeds from other sites related to BT747. One of them concerns the file releases and there is a direct link to download the release. Currently, that is this link.

raymac74's picture

@mdeweerd: I was able to

@mdeweerd:

I was able to connect one time selecting the port:
/dev/tty.usbmodem3d10 (looked by "find serial port")
in the following times I wasn't able to connect anymore, the ports added before were disappeared from the list so I had to re-find serial port, with bad results!!
Anyway, the "Info Windows shows":
----------------------------
25189 -
Listing known ports:
25191 - SER :/dev/tty.usbmodem3d10
25192 - SER :/dev/cu.usbmodem3d10
25192 - SER :/dev/tty.Bluetooth-PDA-Sync
25192 - SER :/dev/cu.Bluetooth-PDA-Sync
25192 - SER :/dev/tty.Bluetooth-Modem
25192 - SER :/dev/cu.Bluetooth-Modem
25192 - SER :/dev/tty.iBTAGPS-SPPslave
25193 - SER :/dev/cu.iBTAGPS-SPPslave

gnu.io.NoSuchPortException
at gnu.io.CommPortIdentifier.getPortIdentifier(CommPortIdentifier.java:218)
at gps.connection.GPSRxTxPort.openPort(Unknown Source)
at gps.connection.GPSrxtx.myOpenPort(Unknown Source)
at gps.connection.GPSrxtx.setBluetoothAndOpen(Unknown Source)
at bt747.model.Controller.setBluetooth(Unknown Source)
at bt747.j2se_view.BT747Main.access$300(Unknown Source)
at bt747.j2se_view.BT747Main$6.actionPerformed(Unknown Source)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2028)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2351)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
at java.awt.Component.processMouseEvent(Component.java:6348)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
at java.awt.Component.processEvent(Component.java:6113)
at java.awt.Container.processEvent(Container.java:2085)
at java.awt.Component.dispatchEventImpl(Component.java:4714)
at java.awt.Container.dispatchEventImpl(Container.java:2143)
at java.awt.Component.dispatchEvent(Component.java:4544)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4618)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4282)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4212)
at java.awt.Container.dispatchEventImpl(Container.java:2129)
at java.awt.Window.dispatchEventImpl(Window.java:2475)
at java.awt.Component.dispatchEvent(Component.java:4544)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:635)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

----------------------------

Each time I try to connect it change the the port but it doesn't connect!!
Any hints? Why the first time it connects?
Thanks,

raymac74

Post new comment

(If you're a human, don't change the following field)
Your first name.
(If you're a human, don't change the following field)
Your first name.
The content of this field is kept private and will not be shown publicly.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <p> <br>
  • Lines and paragraphs break automatically.
  • Use the special tag [adsense:format:slot] or [adsense:format:[group]:[channel][:slot]] or [adsense:block:location] to display Google AdSense ads.
  • Images can be added to this post.

More information about formatting options