Cannot create lock file

schlupp's picture

Hello,

when I run bt747 under Linux as a usual user I cannot create a lock file in /var/lock and so cannot connect to my iBlue GPS logger. The directory permissions should allow creating files, I can create a simple file by the touch command.

When I run bt747 as root (what I don't want to do) everything is fine.

Do you know a solution for my problem? I guess there are some other access rights which have to be reset.

Thanks for a solution

Reinhard

mdeweerd's picture

Hi The "official solution" is

Hi

The "official solution" is to add the user to uucp ("sudo usermod -aG uucp USERNAME").

The other solution is to create the lock file and give everybody access:

sudo mkdir /var/lock
sudo chmod 777 /var/lock

Kind regards

 

Mario

schlupp's picture

Ah, I solved the problem -

Ah, I solved the problem - there were wrong access settings not for the lock directory but in the bt747 libs subdirectory.

Thanks for your help

Reinhard

Post new comment

(If you're a human, don't change the following field)
Your first name.
(If you're a human, don't change the following field)
Your first name.
The content of this field is kept private and will not be shown publicly.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <p> <br>
  • Lines and paragraphs break automatically.
  • Use the special tag [adsense:format:slot] or [adsense:format:[group]:[channel][:slot]] or [adsense:block:location] to display Google AdSense ads.
  • Images can be added to this post.

More information about formatting options

By submitting this form, you accept the Mollom privacy policy.