cannot access iBlue 747 A+ on Mac OS X 10.6 Snow Leopard

gh4507's picture

I have installed various versions of BT747 on a Mac OS 10.6.  Whether accessing my iBlue 747 A+ via Bluetooth or USB,  I constantly get an error that the port is not found.  the /dev ports do exist, and other programs (HoudahGPS) can see both USB and Bluetooth ports so I know that the device can connect.  I have tried several versions of BT747 to no avail.

Any ideas?

    at gps.connection.GPSRxTxPort.openPort(Unknown Source)
    at gps.connection.GPSrxtx.myOpenPort(Unknown Source)
    at gps.connection.GPSrxtx.setUSBAndOpen(Unknown Source)
    at bt747.model.Controller.setUsb(Unknown Source)
    at bt747.j2se_view.BT747Main.access$300(Unknown Source)
    at bt747.j2se_view.BT747Main$7.actionPerformed(Unknown Source)
    at javax.swing.AbstractButton.fireActionPerformed(
    at javax.swing.AbstractButton$Handler.actionPerformed(
    at javax.swing.DefaultButtonModel.fireActionPerformed(
    at javax.swing.DefaultButtonModel.setPressed(
    at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(
    at java.awt.Component.processMouseEvent(
    at javax.swing.JComponent.processMouseEvent(
    at java.awt.Component.processEvent(
    at java.awt.Container.processEvent(
    at java.awt.Component.dispatchEventImpl(
    at java.awt.Container.dispatchEventImpl(
    at java.awt.Component.dispatchEvent(
    at java.awt.LightweightDispatcher.retargetMouseEvent(
    at java.awt.LightweightDispatcher.processMouseEvent(
    at java.awt.LightweightDispatcher.dispatchEvent(
    at java.awt.Container.dispatchEventImpl(
    at java.awt.Window.dispatchEventImpl(
    at java.awt.Component.dispatchEvent(
    at java.awt.EventQueue.dispatchEvent(
    at java.awt.EventDispatchThread.pumpOneEventForFilters(
    at java.awt.EventDispatchThread.pumpEventsForFilter(
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(
    at java.awt.EventDispatchThread.pumpEvents(
    at java.awt.EventDispatchThread.pumpEvents(
239373 -
Listing known ports:
239376 - SER  :/dev/tty.usbmodem3a20
239376 - SER  :/dev/cu.usbmodem3a20
239376 - SER  :/dev/tty.Bluetooth-PDA-Sync
239376 - SER  :/dev/cu.Bluetooth-PDA-Sync
239376 - SER  :/dev/tty.Bluetooth-Modem
239376 - SER  :/dev/cu.Bluetooth-Modem
239376 - SER  :/dev/tty.iBTAGPS-SPPslave
239377 - SER  :/dev/cu.iBTAGPS-SPPslave

Me too. Same system, same

Me too. Same system, same error.

mdeweerd's picture

Hi What is the port name that


What is the port name that you entered and  is it listed in the list provided in the error message?

If you used the default setting (USB for Linux, Mac), I think that BT747 does not yet recognize /dev/cu.iBTAGPS-SPPslave as a GPS port.  Hence you need to enter that directly next to the 'Connect' button.  It is a pull down list, but you can enter text freely, so just enter '/dev/cu.iBTAGPS-SPPslave' there.

Please give me more information and I'll update BT747 to recognize the port too.

gh4507's picture

thanks.  entering the USB

thanks.  entering the USB serial port (/dev/cu.usbmodem3a20) directly enabled it to work.

  I was able to get my bt747


I was able to get my bt747 (transystem) device to connect but was unable to download. Clicking the download button seems to do nothing. I've tried the various download options (smart, full, normal) and while the file gets created, nothing is populated. So please help! Thanks.


mdeweerd's picture

Do you get to see the current

Do you get to see the current position in the GPS information window or any other information there?

If no: did you set the correct speed ?