Slow download from m-1200e

Bild von persep

Hi,

it takes about 15 minutes to download 4 tracks from an holux m-1200e on bluetooh (it takes the same on usb). I've tried with the 3 download methods with no difference. Gpsvisulalizer takes only seconds to dowload.

Below are informational messages that can help during debug.
------------------------------------------------
11067 - BT747 2.X.1811 Build:BT747_mdeweerd.1811.20101113162158911
11068 - Initial: 1063x547  Screen: 1280x1024 Final: 1063x547
11068 - Mac OS X
11069 - ppc
11069 - 10.5.8
11069 - 1.5.0_26
11071 - 32

Bild von persep

I've tried it on my old

I've tried it on my old pc.

Normal download took about 20-30 seconds on usb (this computer hasn't got bluetooth). One think I've noticed is that Smart download work as it supposed to, after I did the normal download I changed it to smart download and it didn't download anything (because it was already downloaded) no the mac it always does a 15 min. download.

Bild von StanislavChachkov

Hi, same problem here. Is

Hi, same problem here. Is there a workaround?

Bild von mdeweerd

When downloading over

When downloading over bluetooth you should know that bluetooth does show some limitations and is more prone to communication errors.

In case of trouble you need to tune the 'Download settings' you can find in the 'Advanced settings'.

The bigger the request/block size, the more data gets transferred in a single request.  So if that transfer goes wrong that is a lot of time lost.  Hence for bluetooth, set this to a number that is no bigger than 4096 and potentially even smaller.

As soon as the block size is set to 4096 or less, the 'read ahead' setting is taken into account.  This setting allows to do some pipelining of the requests to speed up.  '3' is generally a good value.

The timeout value is used to determine the expected response will not arrive.  4 seconds is a good value too normally, but you can play with it.

Bild von StanislavChachkov

Hi! Thanks for the

Hi! Thanks for the answer!!

In fact the second download was much more faster. I suppose the first time it downloads the whole log and the second time only the increment, am I right? I used smart download both times.

Actually I use USB, connect to /dev/cu.HOLUX_M-1200E-SPPslave-1 Speed 115200. It works perfectly (even if this speed seems unsupported by the gps)

 

Thank you for the great tool!

Bild von mdeweerd

Smart download tries to

Smart download tries to perform an incremental download for the memory blocks that may have valid data.

So if you already downloaded data before, the smart download has pretty much nothing to do.

However, this does not mean that with bluetooth the tuning of these settings does not have an effect.

The serial speed is only relevant for some virtual serial ports as the serial speed is used on the real serial link in the GPS device.  The more recent devices do not have a real serial link and speed is not important.

 

Thanks for the praise :-).

Bild von StanislavChachkov

Seems that I was too quick to

Seems that I was too quick to draw conclusions. New download and it is very slow again. Same settings as before, smart download and all.

Maybe I can help debug it? I know Java a little bit. Really don't want to use Windows :-)

Bild von mdeweerd

Download is slow under which

Download is slow under which conditions:

  • Bluetooth;
  • Speed of 38400?

To get to understand the reasons for the slowness, you can log the gps transactions into 'gpsRawDebug.txt' by gps connexion debug - this can reveal communication issues or other things.

Before starting to code, the first thing is to understand what happens on serial link & tune the parameters that are already available without coding.

Bild von StanislavChachkov

No, it's USB

No, it's USB /dev/cu.HOLUX_M-1200E-SPPslave-1, speed 115200 as specified by default.

Funny thing is that last time is was fast again. I started to record a gpsRawLog for each download, I have 2 of them already. "Fast" log is 212KB and "slow" one is 9.8MB. The BT747log.bin is always 4MB.

I will try tomorrow again.

PS: Probably totally unrelated, but time split field in Convert panel seems to have no effect, only date is taken into account.

Bild von StanislavChachkov

After few fast downloads I

After few fast downloads I finally got one slow! I tried to understand the log myself, without success. So I made an archive with the last fast log, the slow log and the raw log file, you can find it here:

http ://share1t.com/pbr9td

Hope that helps

MacOS 10.5 and I use "BT747 Desktop Autoupdate"  V2.X.1868 (19.02.2011)

Bild von StanislavChachkov

Actually, I see that the

Actually, I see that the version I have is of 19.02.2011, and my previous download was before this date, it was 16. It is possible that the version change triggered the complete re-download of the raw log?

Bild von mdeweerd

A version change in BT747

A version change in BT747 does not trigger a new full download.

A log file content change does trigger a new download with a request to approve the log overwrite.

What happened when the download was long, is that hte entire log was fetched, including the 'empty' parts which was because BT747 was not waiting correctly for the used memory information.

I made a change in 2.X.1869.

Bild von StanislavChachkov

I tried two more times,

I tried two more times, unfortunately still slow both times (V2.X.1871). Logs:

http: //share1t.com/opja1l

http: //share1t.com/18h0w4

Bild von mdeweerd

I checked the log content

I checked the log content this time.  According to the log, the device was in "overwrite mode" upon erasal of the flash.

In that case the entire log is downloaded.

Partial download is done only when the device was not in overwrite mode upon erasal.

Bild von StanislavChachkov

Does "Overwrite mode"  mean

Does "Overwrite mode"  mean "owerwrite wen full" in device settings tab? It was always set to this mode.

Bild von mdeweerd

Yes, that is what it

Yes, that is what it means.

I'll check out your 'fast download' to see why it was fast in that case.

Bild von StanislavChachkov

I tried it again right now

I tried it again right now and it was fast. Always the same settings. All I do is: switch gps on, connect, download, disconnect, switch gps off. No other actions. I didn't change the owerwrite mode parameter. The only new thing I did this time was to wait about 1 minute between actions: switch on, wait 1 min, connect, wait 1 min, download.

Log: http ://share1t.com/7hd6ds

V2.X.1871

Thank you!

PS: and yet another fast download using the same procedure! I don't know, but maybe it's just a connection initialization problem? I mean, starting the download before the connection is fully intitalized results in full download?

Has anyone found a way to

Has anyone found a way to mount the Holux 1200e on OS X via the usb port?

When I connect mine, it doesn't show up in the same way a usb drive does. So how do OS X users "empty" the thing? I am able to download the tracks using bt747 but it seems that the tracks stay on the device.
I've read about this on http://wiki.openstreetmap.org/wiki/Holux_M-241 (installing a driver for the USB-chipset used in the device)(the Holux 1200e uses the MTK II GPS Chipset : MTK MT3329) but without getting anywhere.

According to this site (http://wiki.openstreetmap.org/wiki/GPS_Reviews) the 1200e requres a "special usb cable" ? What'up!
According to this site (http://scilib.typepad.com/techreviews/2007/12/bt747-for-mac-a.html)
the Java software BT747 can be used with an additional layer of a driver to be able to access the GPS USB port (they say to read here: http://bt747.wiki.sourceforge.net/).

According to this site (http://gpsd.berlios.de/upstream-bugs.html) the pl2303 driver (now what's that) that causes catatonic state with GPSD.

 

 

shawn


 


Bild von mdeweerd

1. You can try the driver for

1. You can try the driver for MacOS for a Transystem MTKII device - I do not know if that helps:

http://www.transystem.com.tw/product/59/SiLabsUSBDriverDisk.dmg

The PL2303 is  another USB-to-Serial bridge (different from Silicon Labs) which needs another driver.

Kommentar hinzufügen

(If you're a human, don't change the following field)
Your first name.
(If you're a human, don't change the following field)
Your first name.
Der Inhalt dieses Feldes wird nicht öffentlich zugänglich angezeigt.
  • Internet- und E-Mail-Adressen werden automatisch umgewandelt.
  • Zulässige HTML-Tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <p> <br>
  • Zeilen und Absätze werden automatisch erzeugt.
  • Use the special tag [adsense:format:slot] or [adsense:format:[group]:[channel][:slot]] or [adsense:block:location] to display Google AdSense ads.
  • Images can be added to this post.

Weitere Informationen über Formatierungsoptionen