Same position logging

Bild von ceracera

Hi from Serbia. Congrats and thank you for this great app. This is my first post.

I have a Holux M-1200E and, by default, it receives data in 1 sec intervals. I have monitored it since I started BT747 and it updated positions fine in 1 sec intervals. Then, I played a little with BT747 and added some logging data in Device settings and have set the device with Format & Erase button. Now it seems to log the same lat lon positions for a 5-15 consecutive 1 sec logs. It updates time fine but positions are changing only on every 5-15 logs. I reverted to settings it was before I added those in Device settings but that doesn't help. Anyone knows what could be the cause of such thing.

Thanks in advance and sorry for my bad english

Bild von mdeweerd

The only logical reason I can

The only logical reason I can see is that you have set the 'Fix' period to 5 seconds or more.

For any less obvious reasons you need to share what you have on the device settings screen.

I am not English, but your English is fine ;-).

Bild von ceracera

Thanks for your quick answer

Thanks for your quick answer :)

It's not that. Fix is set to 1000 ms. But i just realized that it doesn't do it all the time. It records 4-5 "normal" logs (every fix defferent lat and also lon) and then five or a little more "same" logs (sometimes both coordinates are the same and sometimes is just one and not the other).

I'ts strange because the values are not close to each other (if they were one could say it was since I am standing still).

Bild von ceracera

Here is an example of the

Here is an example of the log. They are all in 1 sec intervals.
















Maybe its some rounding problem with number of digits for lat lon?

Bild von mdeweerd

What software are you using

What software are you using to extract these positions?  BT747?

Send me your BT747Settings.pdb file, the bin file and a snapshot of 'Device Settings'.


Bild von ceracera

OK, I will do that soon as I

OK, I will do that soon as I get home.


Bild von ceracera

  I uploaded a zip file on


I uploaded a zip file on website. It's

File bt747-holux-m-1200e.zip421.28 KB
Bild von mdeweerd

Hi I tried the zip and it

Hi I tried the zip and it looks like it is incomplete (it does not uncompress).

I've attached the file to your message (right click, attach to node).

Bild von ceracera

Here are individual files,

Here are individual files, don't know why that archive is incomplete...
Didn't understand that "right click, attach to node" so I uploaded them again and gave them "holux-" prefix so you'll know which they are.

Hope they are ok know :)


File holux-BT747log.bin576 KB
File holux-BT747SettingsJ2SE.pdb2.57 KB
File holux-Screen shot 2011-03-07 at 17.47.02.png234.86 KB
Bild von mdeweerd

Hi I've used your settings


I've used your settings file and converted the log.

It looks normal to me.  I get up to position 18864 and a track that follows streets and stuff.

Your speed is pretty low and that is likely why lat or lon is seamingly stable.

In more digits, the positions you provided above are:


44.79179382324219 20.474105834960938 44.79179382324219 20.47410011291504 44.79179382324219 20.47408676147461 44.79179382324219 20.474082946777344 44.79179382324219 20.474084854125977 44.79179382324219 20.474082946777344 44.79179382324219 20.47408103942871


where lat is effectively stable, but lon is not.

However, further in the log, when your speed is higher, this is absolutely not the case:


452 07-MAR-11 00:40:54 T TimeStamp DGPS 44.79158020019531 20.474580764770508 453 07-MAR-11 00:40:55 T TimeStamp DGPS 44.79157638549805 20.47458839416504 454 07-MAR-11 00:40:56 T TimeStamp DGPS 44.791568756103516 20.474597930908203 455 07-MAR-11 00:40:57 T TimeStamp DGPS 44.791561126708984 20.474605560302734 456 07-MAR-11 00:40:58 T TimeStamp DGPS 44.79155349731445 20.474607467651367 457 07-MAR-11 00:40:59 T TimeStamp DGPS 44.79154968261719 20.4746150970459 458 07-MAR-11 00:41:00 T TimeStamp DGPS 44.79153823852539 20.474624633789062

I thought that you had this 'observation' throughout the log which mystified me.  However you track is normal and when speed increases the positions are clearly distinct.

Hence the evolution in the lat/lon value is related to a small movements.


For your information: you can see more digits in the BT747 'Track table' by widening the table columns.

And you can see more digits in the output files by setting the number of digits in the 'Output settings' tab.

Bild von ceracera

Thanks for that

Thanks for that explanation.

I thought it's strange cause when, for example, my lat is

44.793171 for 3 consecutive 1sec logs and then fourth log is

44.793167 while I would expect it to be

44.793170 or


but maybe I walked straight along the lat axis :) or something like that, but I guess you're right since it doesn't show on higher speeds...

I just got a M-1200E and previous log that I deleted is full of "same position" logs cause I just walked around with it but this one isn't since I drove a little and didn't analyze it that good... Thanks for pointing out that speed reason.

Also, do you know why does it take for a receiver 10 minutes to start acquiring signal (outside, fine weather...). Is that normal or do I have to restore it's facory settings or something?

Bild von mdeweerd

Hi Here is a simple


Here is a simple calculation.

Around the earth is about 40000km.  So 0.000001° is  about 40000000/360 *0.000001 = 0,11 meters, i.e. 11 cm.  For latitude that value is more or less a constant, for longitudes the distance changes with latitude (when the latitude is 90°, the distance for longitude is 0).

Now 0,11 m/s is 396 m/hour or 0,4km/h which is very close to the speeds that I find in the table.

If the receiver takes 10 minutes to acquire a signal, it probably has a bad reception (can be due to the device itself).
It takes about 15 seconds to receive the data needed to be able to make the position calculation and this message is sent something like every 18 seconds, which is why the specification indicate that 34 seconds or so are needed to acquire a first fix from cold start.  If you miss the start of a message, you need to wait 18s + 15s = 33 seconds to get the message that is sent just after that one.

My iBlue 747 or iblue 747 A+ gets a fix in about 30 seconds - every time.

Bild von ceracera

Great explanation :) Thanks

Great explanation :) Thanks