Ubuntu, J2ME, Holux M1000C

Bild von gusse02

Hi all! I'm fresh in this GPS business. Just got me a Holux M-1000C. I have some trouble getting bt747 work for me.
The mobile J2ME application works in my phone (Sony Ericsson C905) except for conversions. I can do the other stuff but I have no success with conversion. trying to convert to GPX and I get a file but the contents is not what I expect. I get some waypoints and tracks with old timestamps. A couple of trackpoints with correct timestamps but far from all of them.

I tried ezlog for windows and there I get all trackpoints.

I'm also trying to use bt474 with Ubuntu and USB cable. I get a connection but the program can't read from my unit. Neither can it download the log.

I've tried the latest development versions for desktop and mobile.

What is the status? Is it supposed to work with 1000C?

Hope it will work out because it seems to be a cool application!


Bild von mdeweerd

Hi It is supposed to work


It is supposed to work with 1000C. The device has evolved however versus the previous and the log format changed. Some of the commands changed too, but most of the old ones work - including download.

While the core code is the same for the three versions (J2ME, PDA and Desktop), their problems can be different.
I understand that you have problems with the J2ME version (conversion) and problems on Ubuntu (download).
It is important to be clear which problem you have where.

On Ubuntu, another user had a similar problem. I suggest that you have a look at the discussion on Sourceforge for that: https://sourceforge.net/forum/message.php?msg_id=7554206 . This is not for exactly the same device but it looks like the same problem and the solution there was an update of Ubuntu.

Regarding the conversion. BT747 can't tell the log format from the log itself in all cases, and you need to select Holux GR-245. In the J2ME application, you should see 'Default device' initially in the convert menu and you have to open the pull down menu and select M1000C / GR245. In the Desktop application the text did not change yet and you have to select Holux GR245. I do not think that I made the GUI update for the PDA version.
You can copy the bin file from your phone to your desktop and convert there if you want, but conversion on the phone should work too once you set the right device type.

Hopefully you get your two problems solved. I am pretty sure that the conversion issue is just a setting. Regarding the connection on Ubuntu, this may be more trouble. If you do not succeed for the latter, follow the instructions on the thread of sourceofrge and report back here with your observations.

Bild von gusse02

Thanks for your quick reply,

Thanks for your quick reply, really appreciate that!

Yes, I have two separate problems.
1) on my mobile the conversion does not seem to work.
2) on my desktop with Ubuntu the communication seems to fail.

1) Yes I found the device setting and already set it to M1000C. The conversion is not correct.
2) Thanks for the link, interesting. Looks like the problem I have. Debug shows timeout and no ack. Trouble communication with the device it seems.
The tip was to use Debian instead. Accidentally I have Debian on another PC where I tried but I could not connect to the correct port. It kept trying /dev/ttyS1 where I have another serial device.

On windows it works. Here I can see the following about my device:
FlashInfo: C22015C2 (MX,2MB)
Model: 0035 (Holux M1000C)
Firmware: AXN_1.0-B_1.3_C01 (01029-00A)
Logger SW: V1.39

Thanks for your help!

Bild von gusse02

Bug in cdc_acm according to

Bug in cdc_acm according to this post: http://www.bt747.org/node/74 I will try that tonight. I thinj this is the solution to my problem 2).

Bild von gusse02

Yes! Problem #2 is solved.

Yes! Problem #2 is solved. The solution was here: http://www.bt747.org/node/74 I had to patch and build the kernel module cdc_acm. Then the java command also needed -Dgnu.io.rxtx.SerialPorts=/dev/ttyACM0 Now I'm fine with the desktop application. Still having problems with the mobile application though.