TimeZone settings for Holux

Bild von PostPCMan

I'm trying to understand how to set up the time zone settings for my Holux M241. I have the holux set to show local time, which is PST = UTC-8. Of course, I want the log file to have UTC time. I started by setting Output Settings -> TimeZone to UTC+0, since that's what I want the output file to contain, but then the output file contains my local time rather than UTC. Also, Advanced File Settings -> Do Not Apply UTC Offset is off. Should TimeZone be set to UTC-8? Would mean that I want BT747 to add 8 hours to the time it reads from the holux?

In other words, what is the meaning of the TimeZone setting. Does it indicate the setting that I've applied to my gps, which would mean that I want BT747 to reverse that setting? And, why would one turn on "Do Not Apply UTC Offset"? Does the binary file that BT747 gets from the Holux contain info about what time zone it is in, which should enable BT747 to do the right thing automatically?

Thanks for the help, in advance.

Bild von mdeweerd

TimeZone Settings

The 'Do not apply offset' only applies to GPX output formats where the time should be the UTC time.

The UTC time is what I observed to be logged in the loggers up to now.

Now, it is possible that the new firmware version (1.12) does things differently and that it was chosen to log the local time as set on the Holux device. I did not get the latest FW yet, so I can not confirm that. However, V1.11 logs the UTC time (can be checked when setting UTC to 0).

The TimeZone in 'Output Settings' is your local time zone. So if you set 'UTC-8', then BT747 will deduct 8 hours from the time provided by the logger to end up with the UTC-8 time.
If there is some indication in the Holux log of the version used (or indication of the time offset), I can extract that and use it to make BT747 behave as the user expects, but for that I first need to get a log in my hands

So given how your Holux seems to act, you should set UTC+8 to get the UTC+0 time.

Bild von PostPCMan

I was running 1.11 when I

I was running 1.11 when I started this thread, but I just updated to 1.12. I'd be happy to send you a couple of binary log captures with different time settings if you tell me how to do that. I don't see any way to send a private message, and don't know your e-mail address.


Bild von mdeweerd

Contacting me privately

To contact me privately, several solutions:
a) My e-mail is in the about box of the application,
b) There is a contact form on this site,
c) You can use the contact methods on sourceforge.

The behaviour in 1.11 is strange because I tried it myself and UTC is recorded!