position server (myLieu) update too long

Bild von shony


I used this feature now the first time with the gps logger and there is a diffenrece in the costs. I have to pay for the data amount and wondered if the lat lon speed and alt have to be this accurate? I mean if you transmit only 5 or 6 digits right of point it would be enough, or wouldn't it? There is no problem to shorten it at the server side but why transmitting 52.50779166666667 when 52.50780 would satisfy in the first place. AFAIR shorten it to 5 dezimal places means pos+-12cm. If requested I'll calculate it exactly.


example of the stored data on the server

<marker time="2010-03-21T01:26:57+01:00" lat="52.50779166666667" lng="13.481408333333333" speed="0.0" alt="0.0" dir="0.0"/>
<marker time="2010-03-21T01:31:55+01:00" lat="52.508181666666665" lng="13.480605" speed="0.35187998" alt="83.4" dir="329.25"/>
<marker time="2010-03-21T01:36:55+01:00" lat="52.50812333333333" lng="13.480648333333333" speed="1.3334401" alt="86.50001" dir="55.5"/>
<marker time="2010-03-21T01:42:01+01:00" lat="52.504465" lng="13.477215" speed="0.7408" alt="194.29999" dir="108.02"/>
<marker time="2010-03-21T01:46:52+01:00" lat="52.51428" lng="13.472143333333333" speed="27.24292" alt="97.19999" dir="279.18"/>
<marker time="2010-03-21T01:51:56+01:00" lat="52.51717" lng="13.442191666666666" speed="27.24292" alt="26.5" dir="282.69"/>
<marker time="2010-03-21T01:56:57+01:00" lat="52.521948333333334" lng="13.417283333333334" speed="15.51976" alt="41.7" dir="316.79"/>
<marker time="2010-03-21T02:01:59+01:00" lat="52.53170166666666" lng="13.399715" speed="28.26152" alt="20.8" dir="329.75"/>
<marker time="2010-03-21T02:07:02+01:00" lat="52.55028" lng="13.385466666666666" speed="31.224722" alt="47.7" dir="323.73"/>
<marker time="2010-03-21T02:26:56+01:00" lat="52.55154" lng="13.38753" speed="123.56" alt="88.9" dir="23"/>

Bild von mdeweerd

Hi I reduced the precision of


I reduced the precision of the different fields in BT_J2ME_0_3_48.zip .

This is an example of the new payload sent to the server (in my setup, with unknown BT address):


So I guess it may be usefull to keep each field selectable or not too.


Regarding precision, as far as I see it: 360° correspond to about 40000km in the worst case.  So 0.00001 degree corresponds to 1,11 meter worst case.  The error is then +/- 0.6 meters (I round it a bit).  This is in lat and long direction, so the error could be sqrt(2*(0.6^2))= +/-0.8 meters worst case.  Hence - to keep things simple - 5 digits correspond to an error of max 1 meter.

Bild von shony

this was fast... :-) tried

this was fast... :-)

tried the new functionality but regrett to inform that BT connection isn't working anymore with my nokia 6720c. Version 0.3.46 is still working with the minor limitation to have the cancel the BT-connection process by hand after a couple of seconds. If not it is trying to connect for hours but is already connected after seconds.

LOG says "[Warn] Unhandled excepton in hideNotify() of initializing GPS..."

with 0.3.48 it seems not to start the BTconnect at all


PS the idea to select which field to upload sounds very nice. esspecialy the hdop. I'm on it to improve the myLieu server at the moment. adding a bubbles with trk-point information on the map as well as improving the age of dataset recognition (red/green light) It wouldn't be an problem for me to implement HDOP as well.

Bild von mdeweerd

Hi Can you tell me which


Can you tell me which version you were using before these?

I'll try to find out what is happening.


Bild von shony

sorry, sorry meant to do this


sorry meant to do this 0.3.46


Bild von mdeweerd

Ok, so the Bluetooth

Ok, so the Bluetooth connection only completely fails in 0.3.28.  That will simplify finding the differences...

Bild von mdeweerd

I went through the

I went through the difference, but the changes in the code do not seem important to me.

I did change the development environment since the previous build, so I guess that the impact is from there.  I fixed some issues in the GUI library I use and I now consistently get an out of memory problem - one of the issues I solved is related to the 'indefinitive' wait of the connection screen (which is fixed now).

Still, I need to fix the memory issue before making a release again.

Bild von mdeweerd

I fixed some stuff but I can

I fixed some stuff but I can not do the actual trial right now - it looks ok in the emulators.

I added a simple page for easy install over the air on a device:


Bild von shony

I'm sorry to report that

I'm sorry to report that neither version after 0.3.46 is connecting via bluetooth. Just tried the .55. Even tested it with removing the old app completely before. All versions are skipping the discover and connect part, so it looks.

Maybe a bit of topic shall I open a new topic to see if others have the same difficulties?

Bild von mdeweerd

Ok, thanks. I'll have to

Ok, thanks.

I'll have to debug on my side and report back when I think I fixed it.

Bild von mdeweerd

Hi The issue seem(ed) to be


The issue seem(ed) to be with the optimisation process that must have changed after upgrading the dev. environment.

I still can't connect on my phone, but I suspect that to some security setting on my phone - the behaviour has improved.

Therefore, I uploaded a new unoptimized version (0.3.59).  Please let me know if that works for you.

Bild von shony

just checked .60 and .59 the

just checked .60 and .59

the .59 connects and has no wait anymore after the established connection. The unhandled error from the log vanished as well.

regret to inform that the .60 won't connect.

Bild von mdeweerd

Hi I pushed down the revision


I pushed down the revision number a bit and I messed them up apparently - .59 was after .60 so that is a good thing ;-).

I have now rebuilt to .61 and have put that on the server.

I concluded that I definitively have an issue on my phone because .48 will not work for me there.  However, the latest version I tried does take a while to look for devices and ends up telling me that it doesn't find any.  Which is a good thing compared to not looking at all or looking for devices indefinitively.

Bild von shony

still some ideas here your

still some ideas here

  1. your suggestion to select which fields should be sent to the server I'll like very much.
  2. In this the uploading of twice the same information could be disabled (position vs latitude+longitude) I guess position is needed for campatibility reasons?
  3. The dot at direction seems to be needles, or is there a floating-point direction possebility?
  4. On the status page "sending aktive/inactive" an additonal line with the last action timestamp and maybe sent position data could be useful for checking if the position sending is still working. I had the sending on for some time so there were a lot of dots and after leaving the bluetooth range for a couple of seconds the uploading stopped without my registering it.
  5. great would be also if the filepath field in the settings could be allready filled with "setUserPosition.php" I just had to type it to often during the testing ;-). Also I think it would explain this field to new users in a very simple way.


I'll extend the setUserPosition.php on the next weekend fiting all the fields then. I think this is the least I can do (despite the donation ;-) )

[2010-March-23 10:25:3] numsat=4&alt=0.0&user=Shony&latitude=52.08159&btaddr=&speed=0.0&hdop=4.00&position=12.84423,52.08159&longitude=12.84423&dir=0.
[2010-March-23 10:30:3] numsat=5&alt=70.4&user=Shony&latitude=52.08088&btaddr=&speed=0.2&hdop=2.00&position=12.84225,52.08088&longitude=12.84225&dir=293.

Bild von mdeweerd

  ;-) That would indeed be


  1. ;-)
  2. That would indeed be impacted by '1.' - there are some implementations using position rather than lat and lon separately;
  3. I did a 'quick' fix to limit the number of digits and limited it to '0' for direction, but that still gives the dot.  The value is a float indeed.
  4. & 5. Good points.

When updating the code, make sure you use the code that I updated available as a gz as explained on the gps tracking documentation page :BT747mylieu/WebContent.tar.gz

I didn't work on it recently, but it has some improvement versus the original code.

Bild von shony

6. automatic reconnect if BT

6. automatic reconnect if BT connection gets lost as it happens now a kind of regularly :-( . Can't figure out the reason for it didn't touched neither phone nor gps-logger.

manual reconnect doesn't work 'til I power off/on the logger and search for it again.  If it happens again I'll report any new findings.

Bild von shony

System Error [Error]

System Error

[Error] readCheck



SymbianOS error = -6305: General


than manuel reconnect

[Warn] Problem closing GPS connection .....

(quite logical 'cause there is no connection anymore)


try URL....


connection to ....

all fine now just the reconnection has to be started manually if I see there os no connection established anymore.

Bild von mdeweerd

Hi This should help to focus


This should help to focus ;-).  The Symbian OS error is:





However, that is not really mentionned in the Java error which is a 'ConnectionException'.

Bild von mdeweerd

Changed the code a bit to try

Changed the code a bit to try to reconnect when closed connection is detected.

The connection is retried only once.

0.3.61 got overwritten on the sf site - the configuration on a new computer was not set to autoincrement the version yet.  Fixed that and I did rebuild to version 0.3.62.

I let you try that.

I'm using Motorola Rokr E6. 

I'm using Motorola Rokr E6.  I have a external GPS bluetooth receiver from SatGuide.in.  I installed BT747 today and tried to connect to my GPS Bluetooth receiver but it showed javax.bluetooth.blutooth ConnectionException: Connection failure.  [Error] Problem Opening btspp://0019ef110451:2;master=false;encrypt=false;authenticate=false.

I have couple of questions

1. Does Motorola Rokr E6 support serial port connection?

2. While connection, it did not ask for password for my GPS receiver.  The GPS receiver password is 0183.

Could you please help?

Bild von mdeweerd

Bluetooth connection on a

Bluetooth connection on a phone can be tricky.You usually need to associate the device with the phone first.  During this process you would enter the password.  It is also the first time that I see that a GPS Receiver has a password that is not 0000.So associate first, and then try again.Your phone probably supports the Serial Port Profile (SPP).

Good news.  I installed

Good news.  I installed gpsj.eu application in my rokr e6 and it is working fine.  It is able to connect to my gps receiver and it asked me to enter the password.  It is able to show the latitude longitude and all other values from the GPS device.  So it confirms that ROKR E6 supports jsr82 standard but we need to have an application that should make use of jsr82 to connect to bluetooth using the serial port and also need to have an option to use password.

I think you may want to look at your application to support password option too.

Thanks for your response.  I

Thanks for your response.  I had actually tried to connect to the GPS device using the normal bluetooth method available with rokr e6 but it did not bond with the regular method.  But (as mentioned in my previous post) I tried with gps/j application and it was able to connect to my GPS receiver using the serial port with the password.

Bild von mdeweerd

Hi Balu Is the application

Hi Balu

Is the application asking for the password or the phone?

I guess your problem is something to dig into - I do not have much time currently and for this kind of issue it may be pretty much related to the phone.

Can you check if it works after bonding?

I opened GPS/J appliation. 

I opened GPS/J appliation.  The application asked me for permission to turn the bluetooth on and I said yes, then the application showed it tries to connect to my gps receiver, then it showed the Phone's password screen to enter the password and I entered 0183, then it again showed the GPS/J screen and it got connected.  It was able to get the GPS information.

Bild von mdeweerd

Ok, so it is the phone taking

Ok, so it is the phone taking care of the password possibly due to the way the connection is made.