m241 corrupted logs question

Bild von sensovision

I've just returned back from trip from Turkey and my logger bring my unpleasent surprise. I download bin file without problems, but when try to convert it to GPX, BT747 converts only first day before we get to airport, the rest of days have names like this: GPSDATA-19700101.gpx

Shortly before trip I've upgraded to new firmware 1.13

Would you please advice what may cause this, I didn't try to reflash device or do any other actions and decide to ask for advice first. BTW I've failed to downlaod track using GPSBabel as it's report something like this: "11083: Bad CRC 4c != 7a (pos 0x04f444)" and although it download tracks they have weird timing issue also.

Although I'm using Linux in hope to recover logging data, I also found Win machine and tried Holux utility for downloading tracks, after few tries it's manage to download track files with correct timing although it's missing two days of logging info.

I can provide bin file or any other requested info.

Would be very appreciate for any help and ideas what may went wrong.

Bild von mdeweerd

Hi You can send me the '.bin'


You can send me the '.bin' file (mail in the 'about' of the app).  It is likely that the date field was not recorded, but I'll be able to confirm that from the .bin file.

Bild von sensovision

Thanks for help, Mario! I've

Thanks for help, Mario! I've just sent you mail with bzipped bin file. Looking forward to hear back from you.

Bild von mdeweerd

Sensovision's issue has been

Sensovision's issue has been solved.

Basically, Holux changed its logger format again and BT747 had a harder job at recovering from something it did not recognise and as a result had more errors.

I adjusted the reader a bit and errors were reduced to only real issues in the log.  As a result the overall track improved.

Hi,I seem to have a similar


I seem to have a similar issue with recovering the logs from this weekends trip to Copenhagen.

I get the "Bad record(s) @0(00000240) Recovered (00000244)" many times - actually it's approx. 22000 times its written to the log when doing a conversion. And no track files are created :(

When I try to convert to GPX (or any other format), set the Date Filter to start on the 22 and end on the 24 (the weekend), I get the "No output files were created!" warning.

I've tried with the latest version (2.X.1767), and even with the Holux software at work on a windows machine, but no luck.

When connecting the m-241 to BT747, I get a "Device Memory Corrupted" error, when using the latest version, so I assume that could be the cause for my missing logs? But before I erase the m-241 I would ask if there is a possibility my logs could be recovered somehow?

Thanks for a great program!

Jens Peter

Bild von mdeweerd

Hi Jean Actually, 2.X.1767 is

Hi Jean

Actually, 2.X.1767 is not the latest - it is the one proposed by default (that is something that I can not change automatically (yet)).

The fix was done in 2.X.1789.

Once you have downloaded the full memory you have the '.bin' that is a copy of what is in the memory.  You can safely erase the memory after that, while keeping the bin file.  If - after using the real latest version - you still have a lot of recovery messages, you can send me the '.bin' file and I'll have a look.