HTML output not working with google maps v3

Bild von mamahuhu

I have problem with the html generated by v2.1.0+, nothing is displaying in browser. Apparently starting 2.1.0 it's using google maps api v3. My gmapskeys.txt is good and using 2.0.3 the html works fine (with google maps api v2). Anyone having the same issue?

Just noticed the exact same

Just noticed the exact same problem here while trying to generate a map of a recent photo trip.  I've also resorted to using an older version of BT747 specifically to generate the Google Maps HTML file using the v2 API as a short term fix.  I also tried loading the output HTML from the latest version with both Firefox and IE, so it doesn't seem to be a browser rendering issue.

Bild von mdeweerd

With Map V3 you may not need

With Map V3 you may not need to define a key - also if you use a key, you should get a new key.

Google Maps V2 is no longer supported by google and it stopped working for a while.

I got still the same problem.

I got still the same problem. I tried without a key and I tried with a new key. On further investigation I saw that sometimes it did work. When in de generated html the following code is present it does not work:

var baseIcon = new GIcon(G_DEFAULT_ICON);
baseIcon.iconSize = new GSize(32, 32);
var ICONB=new GIcon(baseIcon);ICONB.image='';
var markers;markers=[
 new GMarker(new google.maps.LatLng(47.61431,9.89911),ICONB)];
"<table width=400><tr><td>TIJD:</td><td>04-AUG-14 16:04:47</td></tr><tr><td>RCR:</td><td>B <b>(Drukknop)</b></td></tr><tr><td>GELDIG:</td><td>DGPS</td></tr><tr><td>LATITUDE:</td><td>47.614314 N</td></tr><tr><td>LONGITUDE:</td><td>9.899105 E</td></tr><tr><td>HEIGHT:</td><td>819.103 m</td></tr><tr><td>SNELHEID:</td><td>0.989 km/h</td></tr><tr><td>HEADING:</td><td>168.26816&#176;</td></tr><tr><td>DSTA:</td><td>0</td></tr><tr><td>DAGE:</td><td>0</td></tr><tr><td>PDOP:</td><td>1.36</td></tr><tr><td>HDOP:</td><td>1.04</td></tr><tr><td>VDOP:</td><td>0.87</td></tr><tr><td>AFSTAND:</td><td>0.51 m</td></tr></table>",
for (var i=0; i<markers.length; ++i) {

When I remove this code from a html file it works ok. Maybe it has something to do with special markers (waypoints) in the track ? I sometimes make these markers and I would like to use them.