Give up on MacOS Mavericks?

Bild von steve hoge

I can start up BT747 V2.1.1 on Mavericks 10.9.2 but can't connect to my QStarz BT-1000 anymore, neither through USB nor Bluetooth.

Serial ports for both show up as /dev/tty.QstarzGPS-SPPslave for Bluetooth when paired and /dev/tty.usbmodemfd3440 when USB is plugged in.   Scanning for serial ports ("Populate Serial Port Menu") finds the named /devs.

But BT747 won't connect.  See the console output: it gives an error that the serial ports are already in use.

Still works OK on my 10.8.3 machine.   Is it forever broken on Mavericks?

For Mavericks I installed

For Mavericks I installed silabsusbdriver64.pkg, restartet the computer and connected the 747proS (USB).

Don't forget to setup a new network service ("GPS-Receiver" selected from the dropdownlist) in the system preferences.

Everything is working fine on my IMac / Mavericks with mytracks, also Parallels has  the device to implement in XP or WIN7.

Bild von steve hoge

Thanks, what finally got this

Thanks, what finally got this to work was recreating the /var/lock file with the correct permissions.  This obviously was not preserved when I installed Mavericks on a new disk and restored from backup.

I also installed the latest SiLabs driver, which didn't seem to be on my system, but I'm not sure if that was required because the application myTracks was already seeing my BT-1000.)

The "Network Service" aspect of this setup was unfamiliar to me, and I'm still not sure how to parameterize that network interface for the GPS or why it's required.  I do not have it enabled.



Bild von mdeweerd

Hi Thanks for the feedback.


Thanks for the feedback.  The lock file seems like an old "issue" which can not be fixed from within BT747.

The Silabs driver is not needed for the recent devices - the prove is that the device was already seen by another application.

I am not sure what the 'Network Service' is - is this something that appears during the installation of Silabs?  If yes, then this is a new Silabs feature and you should not worry about it.