BT747 on OSX Mountain Lion / Intel i7 x64 /MBP half 2012

Bild von alf69mi


i have tried several guides and tries but i was not able to use BT747 sw to connect to my iBlue 747 (Transystem) .
Simply it won't connect either via bluetooth or usb (with the SiLab VCP driver)

I had luck with GpsBabel instead, a self and more friendly .dmg installation pkg,
it connects, and downloads/clear the log, but it hasn't any of the dashboard features BT747 has so it's a pity you cannot provide an osx dmg ad well or a working x64 version.  Hope to be able to use bt747 on mac osx in the near future.

Best Regards, Alfredo

Try pairing the device using

Try pairing the device using Bluetooth Manager. The turn on debugging in BT747 and look on the info tab for the ports found. Enter the one that seems to correspond with the port seen under the detailed information in Bluetooth Manager. In my case /dev/tty.Qstarz1000EX-SPPslave worked at 115.2 and 38.4 both.

Also, probably need to create

Also, probably need to create /var/lock, if you haven't already

$ sudo mkdir /var/lock

$ sudo chmod 1777 /var/lock

Bild von alf69mi

Hello Jeff as told before the

Hello Jeff

as told before the Transystem BT747 is paired and is communicating correctly with the Mac using GpsBabel,
if i set the same port on BT747 it won't work, and yes ive checked the /var/lock anf its permissions.

I think the main issue here is Java 7 64 bit, but i don't want to scramble my MacBook pro.
Hope a better BT747 package for Mac will be released, for now i'll stick with GpSBabel on Mac or AndroidMTK on Android.

Just for curiosity, which of the n. links are you using to run BT747?

Thanks again, Alfredo

Hi there, I do have the same

Hi there,

I do have the same problem that I cannot establish a connection btween BT747 and my 747ProS device (using Mac OS). GPSBabel works fine.

Have you found a solution yet?

best regards


Here is what worked for

Here is what worked for me:

BT747 does not suggest the right port by itself. Instead of choosing one of the (not working) ports I put it the port manually (just by copy/paste):


That was it. Connection established. Hope it helps people with the same issue.