Problem converting files

ppopp's picture

I received my new Holux M-241 3 days ago, and was up and running with BT747 fairly quickly. I seem to find a new hitch every time I use it, but then get past it with some trial and error. But now I'm really stuck. Suddenly, this morning, I couldn't convert my log files. I was able to download the log file no problem using the j2se interface, but then got an error message saying the log file might not contain any data, etc.

What is really weird is that I went back to the old interface (bt747_macosx.command) and was able to successfully convert some log files from yesterday. So I cleared the data (using the menu on the logger itself), logged some more data, and was once again able to download the data but not convert it. But then I tried the first log file from earlier in the day and was suddenly able to convert it, but still no luck with the most recent file. I think I need to make a clean start, clear the machine, collect a new log file and try again.

Any ideas what I'm doing wrong here. Every time I think I've developed a system that works, I fail on my next attempt.

Also, I seem to need to run "cat /dev/tty.HOLUX_M-241-SPPSlave-1" in the terminal every time before I can connect to the logger. Is there any way around this?

I'm running OSX 10.5.7 and BT747 v1.68.22 with the both the j2se and older interfaces. Any use in trying the development version?

Any advice would be greatly appreciated.

mdeweerd's picture

Did you set the Device Type

Did you set the Device Type ('far' on the right of the 'Convert to' button) to 'Holux M-241' ?

Sometimes the log has a sufficiently good 'header' to correctly detect it is that type of log, but not in all cases. To be sure it always works, you need to set the option as indicated above.

The development version is not of much use with the Holux M241 device. It currently adds AGPS support, and has more extended Holux M1000C support under development. I started adding direct upload to OSM (ongoing) and made a lot of internal program structure changes that are not directly visibile but that add flexibility for fuutre extension (like AGPS upload).

The 'cat' call can be added to the startup script, but it is the first time I hear about this need.


I tried setting the Device Type to Holux M-241 without success, but I only tried it just before the conversion step (I'm not sure what it was set to when the log file was downloaded).

I'm going to record a new track on the way home from work this evening and try again from scratch, this time setting the device type before the download step.

Strange that it was working the past few days without setting the device type.

I'll try again tonight and report back. Thanks so much for your help.

mdeweerd's picture

The device type is not needed

The device type is not needed for downloading the log file - only for conversion.
As said, the Holux M241 is different from the other logs and it can sometimes be detected automatically - why the device does not always log the same way is not clear.

If you think that there is data in the log and you do not succeed, send me a sample. However, you should try the latest 1.68.XX version (in the development section) which fixes some bugs. I do not think they have an impact for you but they could.

I'm not entirely sure what

I'm not entirely sure what the problem was, but I've got everything working now, twice in the a row with flaws for the first time. So I think I'm on track. I've found the download process works better if the destination folder is empty. Before I download I delete the old log file and move the converted files to another place. I know the program offers to overwrite the exisiting file, but I found the download was hanging. Also, I set the 'Connect' window to "/dev/tty.HOLUX_M-241-SPPSlave-1" instead of just Bluetooth, and that eliminated the need for the 'cat' call run from the terminal.

Thanks so much for your help. You're providing a great service by supporting your program.