Holux M-1000C problems

rt's picture


I am using the autoupdate development version of bt747 (great software, thanks!) with my recently bought Holux M-1000C AXN_1.0-B_1.3_C01 (01029-00A)

I have the following problems:
(1) When downloading the binary log, Altitude and Speed get misreported. It seems that Altitude is reported as Speed (the values here make sense), not sure what happens to the real Speed (the table shows fractions in the range 1.234E-41 - 1.234E-43),
(2) After downloading the log a few times, the device became corrupted, i.e. bt747 was not able to download the log any more. Clearing the log with the vendor supplied software fixed the problem. I am unable to reproduce this issue.
(3) Erase log does not always work.

Any ideas?


mrQQ's picture

Great news! I just returned

Great news!

I just returned from my trip, and have two weeks worth of logs to process - will be a good opportunity to test it :)

rt's picture

I just returned from my trip,

I just returned from my trip, and have two weeks worth of logs to process - will be a good opportunity to test it :)

Hope you enjoyed your trip :)

What are the results of your testing?

muringa182's picture

Guys I really need your

Guys I really need your help!!!!

I got a M 1000C. First day I installed Eztour and got all the log just fine, google earth found the gps nicely too. Mini gps viewer worked either.

Second day, I tried to show Mini gps viewer to my brother. It crashed.

Since them I can't download my log again.... I tried holux suport, they sent me an update and told me to try under other OS. It is named as FW.....

Well I updated the firmware but nothing!!!!! Eztour says my log is 0% it reads the memory and says there is no data on device!!! I tried to reset it, take battery for 3seconds, factory reset, clear log, well I tried everything I could, but it still does not records my log... I don't know if it is windows7 because in xp eztour crashes and don't even connect to the gps...

Guys I'm going crazy with this little thing I almost sent the GPS to hell with a hammer last night!!!!

What to do?? I tried BT747 but it downloads and gives me no file!!!

Actually I'm using Windows 7, Eee pc 1002 ha.

I really liked this thing for the first and single day working... now it a little piece of useless gps....

mdeweerd's picture

The Holux M1000C has a

The Holux M1000C has a slightly different format than the other devices. To convert the file properly you need to set the device type to Holux GR241 (in stead of Default device).

Hopefully that helps.

What else does BT747 tell you (device type, memory filling, ...).

muringa182's picture

Hello thanks for the

Hello thanks for the help!!!

BT 747 says this

Flash info C22015C2
model 0000 (iblue 737/Qstarz 810)
firmware AXN_1.0-B_1.3_C01 (M1000C)
logger SW 1.39
memory used 644 (0%)

Memory used increases very slow i let it on for 4 hours and increases to 1000... I got 7200 already but it said 0% in that case too...

I've put the device as gpr 245 as said here but it keeps saying that nothing was found and no file was created....

mdeweerd's picture

The 0% is pretty strange/ It

The 0% is pretty strange/ It looks like the memory used in bytes indicates '0' while the number of position entries is not 0.
Please share a copy of the transcript with debug on or activate connection debug and share gpsrawdebug.txt (by email to myself - address in the 'about' of the desktop application). Send me the downloaded log file too.

Also:I do not think that you are using the development version - please try that too. It might behave better with the M1000C log.

Finally, it could be that your log filter settings are inappropriate now following your trials: you best deactivate the common filter and tick all boxes in the trackpoint filter to make sure that the problem is not there.

muringa182's picture

Just sent the information

Just sent the information hope you find the wrong pieces in this puzzle!!!

rt's picture

Eztour says my log is 0% it

Eztour says my log is 0% it reads the memory and says there is no data on device!!!

Can you confirm that after you:
1. Run ezTour,
2. Enter GPS configuration and change logging criteria (to anything; just make sure the setting is different than it was); also change GPS device name so that you can see later that the change was indeed done,
3. Click Apply/ OK and ezTour does not complain,
4. Re-enter GPS conf menu and see your changes,

logging still does not work?

Don't worry, your GPS device is unlikely to be broken.

For the future, don't play with the mini gps viewer -- it gave me some trouble, too.

muringa182's picture

Hello there

Hello there everyone!!!!

After a lot of trouble and help from Mario, thanks again, everything is solved.

No matter what I did the device was correctly set in some ways, the only wrong point was with log active/deactive commands. According to Mario there are two bits for that, my device got a wrong setting in both bits so BT747 could not fix the problem at the recover faulty memory button....
That said BT747 got a new version with this bug correction!!!

So now everything works just fine!!!

Thanks everyone for the help!!!


Hello somebody help me, i

Hello somebody help me, i have a simple problem and I wonder if I can use the BT747 library to solve it, I would like to download the data logger in my Holux M1000C for my Java ME application via Bluetooth and then clear the memory, is it possible? if yes how to proceed?

I'm only asking because I found comments about the desktop version for a few mobile post.

I'm trying to use the following workaround, I downloaded the full version of the BT747 and inside the src folder, I copied my project for java me folders from the image below, I made the necessary conversions to run on java me, my doubt now is whether these sources with I will be able to connect to Holux M1000C, and download the data logger and clean the memory? And how to proceed?


It lools like my brand new

It lools like my brand new M1000-C has the same problem as muringa182's one: the device logs points, but when I click "download", bt747 does transfer data but finally gets no track at all. If there is a corrective version that will solve this problem, where could I get it, please?
I can provide log files or testing if necessary.


mdeweerd's picture

@gle: Are you certain that

Are you certain that you set the device type to GR241/M1000C for log conversion (instead of "default")? Apparently I need to update the text in the GUI to show M1000C too.

Downloading and erasing using the J2ME version should be possible. For these operations, the behaviour of the M1000C is not different.
For some operations (like log conditions), it is best to select the right protocol type.
For log conversion, you best set the device type to M1000C.

In Settings/Device Protocol,

In Settings/Device Protocol, "Holux M-1000C / GPSport 245" is selected.

When I press dowload on the main screen, the download takes some time (that is, it seems to actually read data).
The resulting file is here

I do not see any point or track in the map tab. Pressing the CSV conversion button when using M-241 or GR-245 device format gives an error popup "Warning: No outpit files were created! This usually means that either: - The filter did not select any point. - The log does not contain any data. Try selecting all points. If that does not work, it may be a bug [OK] ". Other device format give no error but render a North-South track on the South cost of Ghana

Is it a problem with my M-100C (I can't use it with ezTour either), or is it a bug in bt747? I don't know, but I hope this will be usefull to you in order to have the M-1000C fully supported.

Thanks for you good work,

mdeweerd's picture

This is going to take some

This is going to take some analysis.  The device type should be set to GR-245 as you tried but I confirm that the conversion does not yield valid positions.

The bin file does have data and it does look lile there is position data.

I can only guess that one of the fields that you are logging is not interpreted correctly, but I need to use the debugger to check out what is happening.

mdeweerd's picture

@gle: First level of success

@gle: First level of success - When you set the end date to somewhere in 2030 you'll get a result.  For that, make sure that you use the pull down calendar - there seems to be an issue in setting the date when typing the text only.

Dates are in 2029 - I do not know why yet.  Can you confirm that the time is correct?

mdeweerd's picture

Ok, I can't find a logical

Ok, I can't find a logical transform function.

Integer value for UTC  /  Hex value for UTC / Human readable format:

1873404439  6FA9D3FD // First time in the log (first record, 13 MAY 2029 21:07:09)

1254095999  4ABFFC7F // 27 Sept 2009 23:59:59

Time difference is about 19,63 years.


The hex values do not reveal some inversion of the upper bytes of the time value.

I would suggest to check out the NMEA data.  Currently the desktop application only shows the current time reported by the GPS, not the current date.  I'll have the tooltip text tell the date in the next build.  For now, can you check with some other tool what the standard NMEA data is spitting out?  Is the date correct?

You're rigth about the 2030

You're rigth about the 2030 stuff: Using the tooltip, I have confirmed that when I connect my M-1000C to bt747, the GPS time has the date wrong. Today is "31-MAI-29". The time itself is OK (it shows the current UTC time instead of using my timezone, but it's OK).

I suspect 1254095999 format is "number of seconds since epoch (1970-01-01 00:00:00 UTC)", standard date format for C and Unix. This converts to 27th September 2009, 23:59:59 UTC, which is highly plausible.

It seems we are going forward to a resolution.

Thanks a lot.

mdeweerd's picture

I believe this GPS has AGPS. 

I believe this GPS has AGPS.  I suggest that you clear out the AGPS data.

Other than that - it seems that we know the cause: the GPS has the date wrong, but not the solution.
You can also try a 'factory reset'.

Just saw that Holux released

Just saw that Holux released a firware update for M-1000C, so I upgraded my device to 1.02 (was 1.00 before). Now My M-1000C won't get a GPS lock anymore :-(

I give up for the moment until my Holux M-1000C is working again. Chinese crap really sucks.

Just FYI, the charactestics

Just FYI, the charactestics of the GPS looger have changed after flashing as following:

Model: 0050 (?)
Firmware: AXN_1.30-B_1.3_C01 (01029-00C)

Other values (FlashInfo, Logger SW) are the same

After flashing the v1.02

After flashing the v1.02 firmware, all is working:my M-1000C works with ezTour and BT747, I am able to retrieve correct gps tracks, the date is ok, etc. It's a complete success! Locking on the GPS satellites seems to take more time, though.

I am going to spend the week-end using my M-1000C to test it in order to map my village into OpenStreetMap. Great work!

Thank you for your help and patience.

mdeweerd's picture

It seems that the flashing

It seems that the flashing process is not perfect then - at least it can be repeated.

Possibly the initial problem was a flashing problem too where some constant got flashed the wrong way.

Have fun!

Hi, can I ask, if is posible


can I ask, if is posible to set device in command line download? I use command

run_j2se.bat -a --download-method FULL --device HOLUX245 -p %PORT% -s 38400 -f tmp\gpsdata --outtype GPX --height WGS84_TO_MSL -trkptinfo

for downloading data from holux m-1000c tracker, and

run_j2se.bat -E --device HOLUX245 -p %PORT% -s 38400

command for clearing it.

But at downloading, a got errors. Is there uncommented another device (for example --device m1000c or holuxGR245), and Is the device setting parameter used only at downloading, or at convert too??

Tracker has firmware version 1.03.

If use bt747 1.68.30 i got errors if downloading:

*#0%#***Expected:00011000 Got:00012800 (00000800)
Expected:00011000 Got:00013000 (00000800)
Expected:00011000 Got:00013800 (00000800)
Expected:00011000 Got:00014000 (00000800)


If use bt747 2.X.1510 i got errors if converting:

Time to download data (ms): 29486 ms
Converting to GPX
Input file: gpsdata.bin
Output directory: tmp
Output basename: gpsdata
Bad record(s) @0(000002E0)
Recovered (000002E4)
Bad record(s) @0(00000374)
Recovered (00000378)


Thak you very much for answer


mdeweerd's picture

Hi Vlada Current version

Hi Vlada

  1. Current version numbers are a bit higher that what you are using.  Not that this has a major impact, but it could have an impact for '--device' in the CLI (as far as I remember, there was a bug);
  2. The download issues in 1.68.30 are probably related to a communication problem, not sure this is always the case for you.  BT747 requests a lot of data at once to go faster, but if a packet is not received correctly, the following packets will be reported 'unexpected';
  3. '--device HOLUX245' is the correct way to set the device type for converting.  So unless it is the bug mentioned in '1.', try the conversion in the GUI after setting the right device type and check the 'Info panel'.  If you do not get any errors there (using the same version), then something is wrong in the CLI.   If you do get errors in both locations, either you did not set the correct device type, or you have errors in your log or there is something in the log that BT747 does not understand yet.  Before concluding the 3rd possibility, please try converting using a recent version of BT747 (2.X.1740 is the current one).