Download stops after one fifth with A+ GPS

kurt1232's picture

I'm using now BT747 for 2 years. Now the download in every mode (intelligent, normal, full) stops after about one fifth of downloading. Tried all: other usb port, turning off and on the receiver, ...

Any ideas?

Thanks a lot!

mdeweerd's picture

This is strange. Either the

This is strange.

Either the progress bar is only 1/5th (the real file size is ok, but not the progress bar), or the file size is not complete (in which case the progress bar is correct).  Which is it?  What is the end file size.

There could also be an error in the memory identification (does it still say 4MB on the flashinfo line)?

As I understand your message, downloading stops (it does not "hang").

You can activate 'Debug GPS' /'Debug GPS Connection' in the menu.  The latter creates a gpsRawDebug.txt file that logs all serial transactions which can enable me to identify the issue.

I tried a full download in V2.1.4 where I was able to get the 4MB of memory.

kurt1232's picture

The download 'hangs' after

The download 'hangs' after 1/5. The filesize of BT747log.bin is 774kb after full download. The flash info shows 1C20161C(EON,4MB). I uploaded the gpsRawDebug_kurt1232.txt.

Thanks for helping!

File gpsRawDebug_kurt1232.txt1.62 MB
kurt1232's picture

Now the whole software hangs

Now the whole software hangs under Mac 10.7.3. I cannot quit BT747 and I cannot reboot the Mac as BT747 prevents rebooting!

mdeweerd's picture

I have no hands on experience

I have no hands on experience with mac, but you should be able to kill 'BT747' somehow.

kurt1232's picture

Can you see anything in the

Can you see anything in the uploaded debug file?

mdeweerd's picture

In the log file I noticed

In the log file I noticed that there is no communication coming back from the device.

I suggest that your remove the battery and try again.  There's been a few cases where the device 'locks up' and removing all power from it fixes it.

kurt1232's picture

Unfortunately, same troubles

Unfortunately, same troubles ...

mdeweerd's picture

Ok. I suggest to still make


I suggest to still make sure that your device gets a full reset (removing the battery without USB connection) before the next tries.

In BT747 you can also configure some other Download Settings that are in the 'Advanced Device Settings' tab.

You can reduce the chunk size to a smaller number (512), and if you still run into trouble try to set chunk requests to '0'.  Change these values before starting the download.

Just use the 'Smart download' so that the download picks up where it previously ended - reset the device in between trials.

Once you recovered the content, do a 'Try to recover faulty memory' on your device.  Hopefully that will solve things and get you normal behaviour.

kurt1232's picture

I reduced the chunk size to

I reduced the chunk size to 512 and 0 and both works! Thanks a lot for your great support!