Cannot run bt747_macosX_j2se.command


I am running Mac OS X 10.5.8 on a Powerbook G4 and am having trouble running the bt747_macosX_j2se.command for bt747 2.0.3. I have created the lock file and have been using 2.0.0 without any problems for some time and can continue to use it without any problems.

The error I get when trying to run 2.0.3 is:


Exception in thread "AWT-EventQueue-0" java.lang.NoSuchMethodError: java.text.DateFormatSymbols.getInstance(Ljava/util/Locale;)Ljava/text/DateFormatSymbols;

at org.jdesktop.swingx.plaf.basic.BasicCalendarRenderingHandler.createMonthHeaderStringValue(

at org.jdesktop.swingx.plaf.basic.BasicCalendarRenderingHandler.installProviders(

at org.jdesktop.swingx.plaf.basic.BasicCalendarRenderingHandler.install(

at org.jdesktop.swingx.plaf.basic.BasicCalendarRenderingHandler.<init>(

at org.jdesktop.swingx.plaf.basic.BasicMonthViewUI$RenderingHandler.<init>(

at org.jdesktop.swingx.plaf.basic.BasicMonthViewUI.createRenderingHandler(

at org.jdesktop.swingx.plaf.basic.BasicMonthViewUI.installRenderingHandler(

at org.jdesktop.swingx.plaf.basic.BasicMonthViewUI.installUI(

at javax.swing.JComponent.setUI(

at org.jdesktop.swingx.JXMonthView.setUI(

at org.jdesktop.swingx.JXMonthView.updateUI(

at org.jdesktop.swingx.JXMonthView.<init>(

at org.jdesktop.swingx.JXMonthView.<init>(

at org.jdesktop.swingx.JXDatePicker.initMonthView(

at org.jdesktop.swingx.JXDatePicker.init(

at org.jdesktop.swingx.JXDatePicker.<init>(

at org.jdesktop.swingx.JXDatePicker.<init>(

at bt747.j2se_view.LogOperationsPanel.<init>(Unknown Source)

at bt747.j2se_view.BT747Main.initAppData(Unknown Source)

at bt747.j2se_view.BT747Main.<init>(Unknown Source)

at bt747.j2se_view.BT747Main$ Source)

at java.awt.event.InvocationEvent.dispatch(

at java.awt.EventQueue.dispatchEventImpl(

at java.awt.EventQueue.access$000(

at java.awt.EventQueue$

at java.awt.EventQueue$

at Method)


at java.awt.EventQueue.dispatchEvent(

at java.awt.EventDispatchThread.pumpOneEventForHierarchy(

at java.awt.EventDispatchThread.pumpEventsForHierarchy(

at java.awt.EventDispatchThread.pumpEvents(

at java.awt.EventDispatchThread.pumpEvents(




Any help would be appreciated. BT747 is an excellent software.

mdeweerd's picture

Hi This seems to be related


This seems to be related to a rebuild of the swing library that I operated.

Can you check witht he current developement version ?  I do not expect a change, but at least it makes sure that the issue is also there.

After that I'll check where the issue might come from.

Kind regards


mdeweerd's picture

Hi again It looks like

Hi again

It looks like 'java.text.DateFormatSymbols' is not found which is part of the "standard" library.  It could be that the use of this is new in the latest swingx library.  Possibly the class path must be extended with an extra reference to this library.

I modified the order in which the 'look and feel' is searched which might have an impact on the issue - hopefully positive.

I'll try to get some more information.

Kind regards


I get the same error with the

I get the same error with the dev version 2.X.1922_full. Any ideas yet? I am still able to use 2.0.0 so it isn't the end of the world at the moment.